const regex = /^col\-(sm|xs|md|lg)\-([1-9]|1[0-2])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^col\\-(sm|xs|md|lg)\\-([1-9]|1[0-2])$', 'gm')
const str = `col-sm-1
col-xs-12
col-md-12
col-lg-8
col-sms-1
col-xsd-12
col-xmd-12
col-lgd-8
col-sm-17
col-xs--1
col-md-0
col-lg-122
col-lg-82
col-xs-6
//^col\\-(sm|xs|md|lg)\\-(1|2|3|4|5|6|7|8|9|10|11|12)\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}