# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^col\-(sm|xs|md|lg)\-([1-9]|1[0-2])$"
test_str = ("col-sm-1\n"
"col-xs-12\n"
"col-md-12\n"
"col-lg-8\n\n"
"col-sms-1\n"
"col-xsd-12\n"
"col-xmd-12\n"
"col-lgd-8\n\n"
"col-sm-17\n"
"col-xs--1\n"
"col-md-0\n"
"col-lg-122\n"
"col-lg-82\n\n"
"col-xs-6\n\n\n"
"//^col\\-(sm|xs|md|lg)\\-(1|2|3|4|5|6|7|8|9|10|11|12)$")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.