using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Za-z]|[A-Za-z][\w-]*[A-Za-z0-9])$";
string input = @"ABCDEF
a-_E
_fFGR
-FGFH
5TOTO
AB-DDFD_O0
A5
AAA5CFSDFSD9-
A
B
G
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}