// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z]|[A-Za-z][\w-]*[A-Za-z0-9])$").unwrap();
let string = "ABCDEF
a-_E
_fFGR
-FGFH
5TOTO
AB-DDFD_O0
A5
AAA5CFSDFSD9-
A
B
G
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}