import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Za-z]|[A-Za-z][\\w-]*[A-Za-z0-9])$";
final String string = "ABCDEF\n"
+ "a-_E\n"
+ "_fFGR\n"
+ "-FGFH\n"
+ "5TOTO\n"
+ "AB-DDFD_O0\n"
+ "A5\n"
+ "AAA5CFSDFSD9-\n"
+ "A\n"
+ "B\n"
+ "G\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}