import re
regex = re.compile(r"^([A-Za-z]|[A-Za-z][\w-]*[A-Za-z0-9])$", flags=re.MULTILINE)
test_str = ("ABCDEF\n"
"a-_E\n"
"_fFGR\n"
"-FGFH\n"
"5TOTO\n"
"AB-DDFD_O0\n"
"A5\n"
"AAA5CFSDFSD9-\n"
"A\n"
"B\n"
"G\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")