$re = '/^([A-Za-z]|[A-Za-z][\w-]*[A-Za-z0-9])$/m';
$str = 'ABCDEF
a-_E
_fFGR
-FGFH
5TOTO
AB-DDFD_O0
A5
AAA5CFSDFSD9-
A
B
G
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);