#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[^?\s]*_)(?:\/[-a-zA-Z0-9()@:%_?\+.~#&=]+)+\/?$"
Local $sString = "positives:" & @CRLF & _
"/abc_bcd/def/" & @CRLF & _
"/foo_bar_foo" & @CRLF & _
"" & @CRLF & _
"negatives:" & @CRLF & _
"/foo" & @CRLF & _
"/foo/bar/foo " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ositives:" & @CRLF & _
"/image_supersizer" & @CRLF & _
"/background_remover?s=foo_bar" & @CRLF & _
"" & @CRLF & _
"negatives:" & @CRLF & _
"/image-supersizer" & @CRLF & _
"/imagesupersizer" & @CRLF & _
"/foobar" & @CRLF & _
"/image-supersizer?s=foo_bar" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")