use strict;
my $str = 'positives:
/abc_bcd/def/
/foo_bar_foo
negatives:
/foo
/foo/bar/foo
ositives:
/image_supersizer
/background_remover?s=foo_bar
negatives:
/image-supersizer
/imagesupersizer
/foobar
/image-supersizer?s=foo_bar
';
my $regex = qr/^(?=[^?\s]*_)(?:\/[-a-zA-Z0-9()@:%_?\+.~#&=]+)+\/?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}