import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^?\\s]*_)(?:\\/[-a-zA-Z0-9()@:%_?\\+.~#&=]+)+\\/?$";
final String string = "positives:\n"
+ "/abc_bcd/def/\n"
+ "/foo_bar_foo\n\n"
+ "negatives:\n"
+ "/foo\n"
+ "/foo/bar/foo \n\n\n"
+ "ositives:\n"
+ "/image_supersizer\n"
+ "/background_remover?s=foo_bar\n\n"
+ "negatives:\n"
+ "/image-supersizer\n"
+ "/imagesupersizer\n"
+ "/foobar\n"
+ "/image-supersizer?s=foo_bar\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}