using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[^?\s]*_)(?:\/[-a-zA-Z0-9()@:%_?\+.~#&=]+)+\/?$";
string input = @"positives:
/abc_bcd/def/
/foo_bar_foo
negatives:
/foo
/foo/bar/foo
ositives:
/image_supersizer
/background_remover?s=foo_bar
negatives:
/image-supersizer
/imagesupersizer
/foobar
/image-supersizer?s=foo_bar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}