$re = '/^(?=[^?\s]*_)(?:\/[-a-zA-Z0-9()@:%_?\+.~#&=]+)+\/?$/m';
$str = 'positives:
/abc_bcd/def/
/foo_bar_foo
negatives:
/foo
/foo/bar/foo
ositives:
/image_supersizer
/background_remover?s=foo_bar
negatives:
/image-supersizer
/imagesupersizer
/foobar
/image-supersizer?s=foo_bar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);