const regex = /^(?=[^?\s]*_)(?:\/[-a-zA-Z0-9()@:%_?\+.~#&=]+)+\/?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^?\\s]*_)(?:\\\/[-a-zA-Z0-9()@:%_?\\+.~#&=]+)+\\\/?$', 'gm')
const str = `positives:
/abc_bcd/def/
/foo_bar_foo
negatives:
/foo
/foo/bar/foo
ositives:
/image_supersizer
/background_remover?s=foo_bar
negatives:
/image-supersizer
/imagesupersizer
/foobar
/image-supersizer?s=foo_bar
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}