#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\d+\s*\..*?)(\d+\s*\..*?)(\d+\s*\..*?)(?=\d+\.|$)"
Local $sString = "Suggestions for restaurants:1. Pizza2. Burger3. Sushi4. Noodles..." & @CRLF & _
"" & @CRLF & _
"I tried using regex but it still gives me gthe same output. like for example for any input: " & @CRLF & _
"" & @CRLF & _
"1 . Pizza2. Burger3. Sushi4. Noodles . " & @CRLF & _
"" & @CRLF & _
"I get the output 1 . Pizza2. Burger3. Sushi4. Noodles . Same without any proper numbering within the list"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")