import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\d+\\s*\\..*?)(\\d+\\s*\\..*?)(\\d+\\s*\\..*?)(?=\\d+\\.|$)";
final String string = "Suggestions for restaurants:1. Pizza2. Burger3. Sushi4. Noodles...\n\n"
+ "I tried using regex but it still gives me gthe same output. like for example for any input: \n\n"
+ "1 . Pizza2. Burger3. Sushi4. Noodles . \n\n"
+ "I get the output 1 . Pizza2. Burger3. Sushi4. Noodles . Same without any proper numbering within the list";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}