$re = '/\b(\d+\s*\..*?)(\d+\s*\..*?)(\d+\s*\..*?)(?=\d+\.|$)/m';
$str = 'Suggestions for restaurants:1. Pizza2. Burger3. Sushi4. Noodles...
I tried using regex but it still gives me gthe same output. like for example for any input:
1 . Pizza2. Burger3. Sushi4. Noodles .
I get the output 1 . Pizza2. Burger3. Sushi4. Noodles . Same without any proper numbering within the list';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);