import Foundation
let pattern = #"\b(\d+\s*\..*?)(\d+\s*\..*?)(\d+\s*\..*?)(?=\d+\.|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Suggestions for restaurants:1. Pizza2. Burger3. Sushi4. Noodles...
I tried using regex but it still gives me gthe same output. like for example for any input:
1 . Pizza2. Burger3. Sushi4. Noodles .
I get the output 1 . Pizza2. Burger3. Sushi4. Noodles . Same without any proper numbering within the list
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)