import re
regex = re.compile(r"\b(\d+\s*\..*?)(\d+\s*\..*?)(\d+\s*\..*?)(?=\d+\.|$)", flags=re.MULTILINE)
test_str = ("Suggestions for restaurants:1. Pizza2. Burger3. Sushi4. Noodles...\n\n"
"I tried using regex but it still gives me gthe same output. like for example for any input: \n\n"
"1 . Pizza2. Burger3. Sushi4. Noodles . \n\n"
"I get the output 1 . Pizza2. Burger3. Sushi4. Noodles . Same without any proper numbering within the list")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")