package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Script exception for job id \'\w*\d*\' : (?<message>[^\.]*)`)
var str = `Script exception for job id 'ABc12345' : Too many rows: 500.
Script exception for job id 'XyZ78943' : Too many DMLs: 20.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}