use strict;
my $str = 'Script exception for job id \'ABc12345\' : Too many rows: 500.
Script exception for job id \'XyZ78943\' : Too many DMLs: 20.';
my $regex = qr/Script exception for job id \'\w*\d*\' : (?<message>[^\.]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}