import re
regex = re.compile(r"Script exception for job id \'\w*\d*\' : (?<message>[^\.]*)", flags=re.MULTILINE)
test_str = ("Script exception for job id 'ABc12345' : Too many rows: 500.\n\n"
"Script exception for job id 'XyZ78943' : Too many DMLs: 20.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")