import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Script exception for job id \\'\\w*\\d*\\' : (?<message>[^\\.]*)";
final String string = "Script exception for job id 'ABc12345' : Too many rows: 500.\n\n"
+ "Script exception for job id 'XyZ78943' : Too many DMLs: 20.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}