$re = '/Script exception for job id \'\w*\d*\' : (?<message>[^\.]*)/m';
$str = 'Script exception for job id \'ABc12345\' : Too many rows: 500.
Script exception for job id \'XyZ78943\' : Too many DMLs: 20.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);