re = /Script exception for job id \'\w*\d*\' : (?<message>[^\.]*)/m
str = 'Script exception for job id \'ABc12345\' : Too many rows: 500.
Script exception for job id \'XyZ78943\' : Too many DMLs: 20.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end