#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{2})(\s?)(9?\d{4})(-?)\d{4}"
Local $sString = "11 8765-1234" & @CRLF & _
"11 98765-1234" & @CRLF & _
"118765-1234" & @CRLF & _
"11 87651234" & @CRLF & _
"11987651234" & @CRLF & _
"" & @CRLF & _
"119876512345 = muitos números não validaria" & @CRLF & _
"11876541234 = muitos números sem o 9 também não validaria." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")