import re
regex = re.compile(r"^(\d{2})(\s?)(9?\d{4})(-?)\d{4}", flags=re.MULTILINE)
test_str = ("11 8765-1234\n"
"11 98765-1234\n"
"118765-1234\n"
"11 87651234\n"
"11987651234\n\n"
"119876512345 = muitos números não validaria\n"
"11876541234 = muitos números sem o 9 também não validaria.\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")