const regex = /^(\d{2})(\s?)(9?\d{4})(-?)\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2})(\\s?)(9?\\d{4})(-?)\\d{4}', 'gm')
const str = `11 8765-1234
11 98765-1234
118765-1234
11 87651234
11987651234
119876512345 = muitos números não validaria
11876541234 = muitos números sem o 9 também não validaria.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}