// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{2})(\s?)(9?\d{4})(-?)\d{4}").unwrap();
let string = "11 8765-1234
11 98765-1234
118765-1234
11 87651234
11987651234
119876512345 = muitos números não validaria
11876541234 = muitos números sem o 9 também não validaria.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}