import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{2})(\\s?)(9?\\d{4})(-?)\\d{4}";
final String string = "11 8765-1234\n"
+ "11 98765-1234\n"
+ "118765-1234\n"
+ "11 87651234\n"
+ "11987651234\n\n"
+ "119876512345 = muitos números não validaria\n"
+ "11876541234 = muitos números sem o 9 também não validaria.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}