using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\]]+)]\s(?<Warning>.*)\suser:\s(?<user>[^ ]*)\s([^\(]*)\((?<message>[\w\s]*)\)";
string input = @"2023-02-10 13:01:59 30 [Warning] Aborted connection 30 to db: 'unconnected' user: 'unauthenticated' host: '172.17.0.1' (This connection closed normally without authentication)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}