re = /^([^\]]+)]\s(?<Warning>.*)\suser:\s(?<user>[^ ]*)\s([^\(]*)\((?<message>[\w\s]*)\)/m
str = '2023-02-10 13:01:59 30 [Warning] Aborted connection 30 to db: \'unconnected\' user: \'unauthenticated\' host: \'172.17.0.1\' (This connection closed normally without authentication)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end