// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([^\]]+)]\s(?<Warning>.*)\suser:\s(?<user>[^ ]*)\s([^\(]*)\((?<message>[\w\s]*)\)").unwrap();
let string = "2023-02-10 13:01:59 30 [Warning] Aborted connection 30 to db: 'unconnected' user: 'unauthenticated' host: '172.17.0.1' (This connection closed normally without authentication)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}