$re = '/^([^\]]+)]\s(?<Warning>.*)\suser:\s(?<user>[^ ]*)\s([^\(]*)\((?<message>[\w\s]*)\)/m';
$str = '2023-02-10 13:01:59 30 [Warning] Aborted connection 30 to db: \'unconnected\' user: \'unauthenticated\' host: \'172.17.0.1\' (This connection closed normally without authentication)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);