use strict;
my $str = '2023-02-10 13:01:59 30 [Warning] Aborted connection 30 to db: \'unconnected\' user: \'unauthenticated\' host: \'172.17.0.1\' (This connection closed normally without authentication)';
my $regex = qr/^([^\]]+)]\s(?<Warning>.*)\suser:\s(?<user>[^ ]*)\s([^\(]*)\((?<message>[\w\s]*)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}