#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\/node_modules(?=\/).*\/bin\/).*\/bin\/.*"
Local $sString = "/something/file.txt" & @CRLF & _
" <- not ignored " & @CRLF & _
"/something/bin/file.txt" & @CRLF & _
" <- ignored" & @CRLF & _
"/something/node_modules/anything/bin/file.txt" & @CRLF & _
" <-not ignored" & @CRLF & _
"/something/node_modules/bin/anything/file.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")