use strict;
my $str = '/something/file.txt
<- not ignored
/something/bin/file.txt
<- ignored
/something/node_modules/anything/bin/file.txt
<-not ignored
/something/node_modules/bin/anything/file.txt';
my $regex = qr/^(?!.*\/node_modules(?=\/).*\/bin\/).*\/bin\/.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}