$re = '/^(?!.*\/node_modules(?=\/).*\/bin\/).*\/bin\/.*/m';
$str = '/something/file.txt
<- not ignored
/something/bin/file.txt
<- ignored
/something/node_modules/anything/bin/file.txt
<-not ignored
/something/node_modules/bin/anything/file.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);