const regex = /^(?!.*\/node_modules(?=\/).*\/bin\/).*\/bin\/.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\\/node_modules(?=\\\/).*\\\/bin\\\/).*\\\/bin\\\/.*', 'gm')
const str = `/something/file.txt
<- not ignored
/something/bin/file.txt
<- ignored
/something/node_modules/anything/bin/file.txt
<-not ignored
/something/node_modules/bin/anything/file.txt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}