using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\/node_modules(?=\/).*\/bin\/).*\/bin\/.*";
string input = @"/something/file.txt
<- not ignored
/something/bin/file.txt
<- ignored
/something/node_modules/anything/bin/file.txt
<-not ignored
/something/node_modules/bin/anything/file.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}