re = /^(?!.*\/node_modules(?=\/).*\/bin\/).*\/bin\/.*/m
str = '/something/file.txt
<- not ignored
/something/bin/file.txt
<- ignored
/something/node_modules/anything/bin/file.txt
<-not ignored
/something/node_modules/bin/anything/file.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end