#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)Notif\[\d+\][^NF]*(?:(?:N(?!otif)|F(?!inish))[^NF]*)*"
Local $sString = "Notif[0]:" & @CRLF & _
"some text multiple line" & @CRLF & _
"Notif[1]:" & @CRLF & _
"multiple line text" & @CRLF & _
"Notif[2]:" & @CRLF & _
"text again" & @CRLF & _
"Notif[3]:" & @CRLF & _
"text again" & @CRLF & _
"Finish"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")