re = /Notif\[\d+\][^NF]*(?:(?:N(?!otif)|F(?!inish))[^NF]*)*/
str = 'Notif[0]:
some text multiple line
Notif[1]:
multiple line text
Notif[2]:
text again
Notif[3]:
text again
Finish'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end