import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Notif\\[\\d+\\][^NF]*(?:(?:N(?!otif)|F(?!inish))[^NF]*)*";
final String string = "Notif[0]:\n"
+ "some text multiple line\n"
+ "Notif[1]:\n"
+ "multiple line text\n"
+ "Notif[2]:\n"
+ "text again\n"
+ "Notif[3]:\n"
+ "text again\n"
+ "Finish";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}