using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Notif\[\d+\][^NF]*(?:(?:N(?!otif)|F(?!inish))[^NF]*)*";
string input = @"Notif[0]:
some text multiple line
Notif[1]:
multiple line text
Notif[2]:
text again
Notif[3]:
text again
Finish";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}