const regex = /Notif\[\d+\][^NF]*(?:(?:N(?!otif)|F(?!inish))[^NF]*)*/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Notif\\[\\d+\\][^NF]*(?:(?:N(?!otif)|F(?!inish))[^NF]*)*', 'sg')
const str = `Notif[0]:
some text multiple line
Notif[1]:
multiple line text
Notif[2]:
text again
Notif[3]:
text again
Finish`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}