const regex = /([^-]+)-([^-]+)-([^-]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^-]+)-([^-]+)-([^-]+)', 'gm')
const str = `Mavis Dracula - ZZ - 001.jpg`;
const subst = `word1 - word2 - word3 from $3, $2, $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);