re = /([^-]+)-([^-]+)-([^-]+)/m
str = 'Mavis Dracula - ZZ - 001.jpg'
subst = 'word1 - word2 - word3 from $3, $2, $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result