import Foundation
let pattern = #"([^-]+)-([^-]+)-([^-]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Mavis Dracula - ZZ - 001.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"word1 - word2 - word3 from $3, $2, $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)