const regex = /^([a-z][\w-]{0,255}\.)*([a-z][\w-]{2,255}\.)(gov|edu|mil)(\.[a-z]{2})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z][\\w-]{0,255}\\.)*([a-z][\\w-]{2,255}\\.)(gov|edu|mil)(\\.[a-z]{2})?$', '')
const str = `b2.a1.a21.edu.tr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}