use strict;
my $str = 'b2.a1.a21.edu.tr';
my $regex = qr/^([a-z][\w-]{0,255}\.)*([a-z][\w-]{2,255}\.)(gov|edu|mil)(\.[a-z]{2})?$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}